Author Topic: wattOS-R10 and the Mouse who slept  (Read 2569 times)

biffster

  • wattOS - head nerd
  • Administrator
  • Sr. Member
  • *****
  • Posts: 217
    • View Profile
wattOS-R10 and the Mouse who slept
« on: September 02, 2016, 04:49:21 PM »
So there have been several reports related to USB mice and issues with sleeping or not being recognized, etc. There is likely a simple fix, so give it a try.

- First when reporting a problem, details are helpful. There are thousands of combinations out there. I happen to have 4 logitech bluetooth mice on my various systems, and none of them exhibit the problems reported on wattOS R10 32 and 64bit (i tested). Also does not seem to bother trackpads...so USB mice. (I tested 2 desktops and 4 laptops prior)

- So I dug around and found an old Microsoft bluetooth mouse, and was able to replicate the behavior.

- Teejay has noted a couple of links that will likely fix your problem by getting into the weeds a little. I have not tested those on wattOS, but have used in previous releases and works fine. Again related to blacklisting your specific USB-HID device, or port.

OR

- You can go the simple route. Screenshot is below, and the popup dialog that goes with it is kinda funny if you read it.

    - In any case, open the menu, Go to "System Tools"  - Then "Laptop Mode Tools Configuration"
    - Enter your password when prompted - click ok when it says your running as root.
    - UN-check the "Enable Module runtime-pm" - (see screenshot)
    - Click on OK - then OK again - Close the app
    - Reboot your system
    - Your mouse should no longer go to sleep



This method fixed my misbehaving Microsoft mouse that was doing was has been reported. It might also fix the "not responsive mouse" at boot also - but try it and let us know.

** Also on a unrelated note - We have always prided ourselves on being a "kind" community - helpful, etc. Lets please continue to be that way please. I have received several direct messages from people that have not been so. Things like "what a joke", etc. ** Its not productive or appreciated. If you want to be "leet" go install Arch or Gentoo (which I ran both for several years) and let them tell you to RTFM. Its highly likely any problem you run in to has already been found, and someone will know the answer. AND we can share the answer in a way that is helpful to all. **

- Steps off soapbox -

Dan

  • Sr. Member
  • ****
  • Posts: 191
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #1 on: September 02, 2016, 05:52:36 PM »
Rather than waiting to try this fix on the USB that I installed R10 on, I went ahead and did a full install onto my old HP dx5150 SFF...on which I just upgraded the memory from 1 GB to 4 GBs yesterday.  ;D

This works! Thanks biff!

I'll install it on my laptop later.  :D

As for those with unkind messages...I hope they will take the time to read what the intent of wattOS is from the website.  ;)

billwho

  • Full Member
  • ***
  • Posts: 34
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #2 on: September 02, 2016, 09:10:43 PM »
Older Dell wired usb mouse
UN-check the "Enable Module runtime-pm" FIXED the problem.
Thank you.
Is "Laptop Mode Tools Configuration" new to R10?
LXDE R9 did not have the mouse problem.


teejay

  • wattOS Veteran
  • Sr. Member
  • ****
  • Posts: 80
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #3 on: September 03, 2016, 12:38:38 PM »
MUCH better than my notes, Biff. 

UNchecking runtime-pm would, I assume, affect other devices too.  I speculate that it might improve network performance for some users, which would be a nice side effect.  Are there any negative consequences, potential or inevitable, which might push users to the more detailed solution .... among the weeds, as you put it ?    I'm guessing that printers, scanners and the like go to low-power at their own behest; what of HDDs and other internal devices ?  Or LAN polling, for that matter. 
Anything that might chew up enough cpu or power (whence heat) to become noticeable on a modest machine ?

Looked at another way, what benefit do those using a ps2 mouse or compliant usb meese get over  those who make this change out of necessity ?

silver

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #4 on: September 07, 2016, 12:35:09 PM »
Is there a way to make a fix work while using wattOS as a Live CD?   
« Last Edit: September 09, 2016, 11:29:25 AM by silver »

tonny

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #5 on: September 07, 2016, 06:29:17 PM »
thnx. i was wondering why the touchpad worked but usb mouse needs a button press every time to start moving again.  ;D

Dan

  • Sr. Member
  • ****
  • Posts: 191
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #6 on: September 07, 2016, 11:13:04 PM »
Is there a way to make a fix work while using the wattOS as a Live CD?
Not to my knowledge...perhaps someone else may know if that's possible. Sorry.

silver

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #7 on: September 08, 2016, 08:14:24 PM »
After doing some research, it turns out biffster's fix works for a Live CD as well.

Since you don't want to reboot your computer when using the Live CD, instead unplug your USB devices and plug them back in after doing the fix.

Both my usb mouse and usb keyboard now work.

« Last Edit: September 09, 2016, 11:30:35 AM by silver »

Dan

  • Sr. Member
  • ****
  • Posts: 191
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #8 on: September 08, 2016, 08:18:31 PM »
GREAT! Thanks for providing that information silver!

bob

  • Full Member
  • ***
  • Posts: 37
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #9 on: September 15, 2016, 07:39:33 PM »
Yep, me being stupid I thought my keyboard was broke so went out and purchased a new keyboard *laughs* good to know it can be fixed.
I needed a new keyboard anyway! xD

berliner

  • Full Member
  • ***
  • Posts: 29
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #10 on: October 05, 2016, 10:21:25 PM »
Good news:
The  unchecking of that option did the job for my Dell-PC.
I was wondering about the "laptop" configuration menu because the USB-mouse stopped working on my PC, but since the fix worked I am happy.

Before I found this fix, I tested other distros. There the mouse worked fine.
Only wattOS R10 produced the dead mouse consistent.
I had to unplug it and plug it in again and for that session the mouse did work, but not after restart.

Thanks biffster to the solution.
If possible there is a fix for this "out of the box" ? somehow in the future ?

alpage2

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: wattOS-R10 and the Mouse who slept
« Reply #11 on: October 31, 2016, 06:56:26 AM »
This fix has worked fine on my Acer One Netbook: AOA110, with a USB microsoft mouse.

Alan