Author Topic: Unable to install libpulse-dev on fresh install of R10  (Read 56 times)

martinc

  • Newbie
  • *
  • Posts: 3
    • View Profile
Unable to install libpulse-dev on fresh install of R10
« on: December 01, 2017, 11:01:48 PM »
I've just installed WattOS R10 on an old ThinkPad, and am definitely liking how snappy it is. However, I'm unable to install libpulse-dev.

When I first try:

$ sudo apt-get install libpulse-dev
[…]
The following packages have unmet dependencies:
 libpulse-dev : Depends: libglib2.0-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

To get more detail, I then try:

$ sudo apt-get install libglib2.0-dev
[…]
The following packages have unmet dependencies:
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.48.0-1ubuntu4) but 2.48.1-1~ubuntu16.04.1 is to be installed
                  Depends: libglib2.0-bin (= 2.48.0-1ubuntu4) but 2.48.1-1~ubuntu16.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Puzzled, I do this:

$ dpkg -l | grep libglib2
ii  libglib2.0-0:i386                          2.48.1-1~ubuntu16.04.1                     i386         GLib library of C routines
ii  libglib2.0-bin                             2.48.1-1~ubuntu16.04.1                     i386         Programs for the GLib library
ii  libglib2.0-data                            2.48.1-1~ubuntu16.04.1                     all          Common files for GLib library

and also look the guilty packages up at https://packages.ubuntu.com/. Sure enough, R10 has newer versions installed than those that are part of xenial / 16.04LTS (but older than xenial-updates).

Before someone suggests it, doing the whole update / upgrade thing:

$ sudo apt-get clean
$ sudo apt-get update
$ sudo apt-get autoremove
$ sudo apt-get upgrade
$ sudo apt-get dist-upgrade

makes no difference whatsoever. I get the exact same errors after as before.

I'm a relative newcomer to package version mismatch resolution in Linux land, but I don't see how I can resolve the conflict. Given the huge list of other packages that depend on the ones that are causing the problem here, I don't really want to be futzing with those by attempting to downgrade.

I need libpulse-dev because it's a dependency of qsstv, which I'm trying to build from source. I've tried this on an LXLE install, also based on 16.04LTS, and it works without a hitch.

Any thoughts?

blaze

  • wattOS Veteran
  • Sr. Member
  • ****
  • Posts: 400
  • blazing away
    • View Profile
Re: Unable to install libpulse-dev on fresh install of R10
« Reply #1 on: December 05, 2017, 09:10:53 PM »
I do not have a clue, as usual.  ;D

Could it be that the LXLE install have some additions to the source list that wattOS does not have?
How To Ask Questions The Smart Way; http://www.catb.org/~esr/faqs/smart-questions.html

... and when SOLVED, please edit thread title in first post! :)

leenie

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 136
    • View Profile
Re: Unable to install libpulse-dev on fresh install of R10
« Reply #2 on: December 05, 2017, 10:23:45 PM »
Did you fully update first?

martinc

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Unable to install libpulse-dev on fresh install of R10
« Reply #3 on: December 06, 2017, 01:16:17 AM »
@blaze, it appears to be related to package versions rather than a difference in the set of packages itself. WattOS seems to have later versions of some packages, causing the incompatibility I'm running into.

@leenie, by "fully update", do you mean something different from the set of commands I mentioned (i.e. sudo apt-get clean / update / autoremove / upgrade / dist-upgrade)? If so, please let me know what else I should be doing.

leenie

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 136
    • View Profile
Re: Unable to install libpulse-dev on fresh install of R10
« Reply #4 on: December 06, 2017, 01:19:47 AM »
I usually use synaptic to update, reload, mark all upgrades and apply. Wattos 10  Is based on Ubuntu 16.04. I am still using wattOs R9 because of the and graphics drivers. I have R 10 on a notebook and it works very nice. Maybe say exactly what you are trying to install? Libpulse-dev has to be part of something else.
« Last Edit: December 06, 2017, 01:28:43 AM by leenie »

martinc

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Unable to install libpulse-dev on fresh install of R10
« Reply #5 on: December 06, 2017, 03:10:25 AM »
Problem solved. I opened 'Software & Updates', went to the 'Updates' tab, and checked 'Recommended updates (xenial-updates)'. After that, and a 'sudo apt-get update', I was able to install libpulse-dev successfully (and ultimately build qsstv).

I'm a little puzzled as to why 'Recommended updates' wouldn't be checked by default when I installed WattOS, given that they're, um, recommended. But it looks like I'm all set now.