Author Topic: disable wifi adapter on microWattOS 10.  (Read 164 times)

gychang

  • Newbie
  • *
  • Posts: 6
    • View Profile
disable wifi adapter on microWattOS 10.
« on: April 07, 2017, 12:59:47 AM »
I have 2 wifi adapters, and I simply want to disable the top one (wlx....) on boot, how to do?

--
apai3-Main~$ iwconfig

wlxec086b18693e  IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
wlp3s0    IEEE 802.11abg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
lo        no wireless extensions.

enx74da38afb7a1  IEEE 802.11AC  ESSID:"CHANG5"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:5.18 GHz  Access Point: 60:E3:27:3C:5D:0C   
          Bit Rate:434 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=70/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

apai3-Main~$

--
---
Loving the MicroWatt OS...
---

cheiron

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 131
  • Site Moderator for Planetwatt.com
    • View Profile
Re: disable wifi adapter on microWattOS 10.
« Reply #1 on: April 07, 2017, 02:07:57 PM »
in terminal try this command..


rfkill list


that should list all the devices.. then rfkill block <adapterindex> (you can unblock by changing block to unblock)


Then add command to /etc/rc.local