Forums » Tips and Tricks

LXDM Shows Desktop Environments We Can't Use

  • March 4, 2012 3:18 AM PST

    That problem predated R5. That also happened in R4. Here's how to solve it:go to /usr/share/xsessions and delete files other than ''LXDE''. Problem solved.

    • 170 posts
    March 4, 2012 6:02 AM PST
    I like this!! But what if you want to use another DE after deleting? I will have to experiment...
  • March 4, 2012 6:28 AM PST
    I installed MATE (Only to find it too unstable, so I dropped it, aafftteerr being able to log in to it. So yes, it's possible
    • 563 posts
    March 4, 2012 2:59 PM PST
    I left the other sessions in there because I had customized and removed in previous releases and also edited the lxdm config quite a bit, (no bottom bar, language bar, etc)and folks did not like that, so I added it back in and left it more "stock".
  • March 9, 2012 4:25 AM PST
    Yes, I think I also complained about that in R4, but what I said isn't about removing that function, just getting rid of the DEs I can't actually log in to, which is a different matter, if you ask me.
    • 563 posts
    March 9, 2012 10:16 AM PST
    Yep. that is an outlier and I knew it when I released R5. I did not have time to make sure and test all the other DE's and make sure they properly "re-add" the menu option to the LXDM interface if I were to manually remove them. So I left it stock.