Forums » wattOS R8

Update Manager and administrative rights on R8

    • 105 posts
    May 12, 2014 12:34 PM PDT

    To use update manager, click lightbulb, run, enter "gksu-properties" and change the "su" to "sudo" then close.. and now you can run update manager

  • May 12, 2014 5:03 PM PDT

    Please notice that you do not perform what gerry beale contributes it to in update maneger not starting.

    "lightbulb" is new wattOS logo definitely. (This is operation for LXDE, what go "open the menu")


    but I noticed that an update manager did not work by a different problem in my environment.

    A problem seems to occur in gksu. 

    I worked again and confirmed improvement.


    This post was edited by BALLOON a.k.a. Fu-sen. at May 13, 2014 2:38 AM PDT
    • 105 posts
    May 12, 2014 10:44 PM PDT

    I did make a little mistake on my last post.. the lightbulb was 7.5 and earlier editions.......

     

    For those on newer versions of watt... its the bottom left corner (volume dial looking icon) *my bad*

     

    This article was written for 32 bit lxde wattos r8 (which i have fully installed and running at time of this .. and last post.. on virtual machine)

     

    in the "start menu" , bottom left corner, you click on that , click run, then type gksu-properties  this will list the sudo options.. 

     

    you will see the menu come up saying "Privilege Granting Preferences" 

     

    it has 2 options ...  Behaviour  <----->  Screen Grabbing

     

    Behaviour by default is set to su 

     

    this has to change to sudo.

     

    Then update manager will work correctly.

     

    My post was accurate apart from the lightbulb icon. I retested this morning to double check on a clean install on vm as on testing the beta builds i encountered this issue and was given this advice by BiffBaxter  "Can you launch either from command line with sudo? Also check gksu-properties and see if it's su or sudo (should be sudo)" when i queried update manager problems

  • May 13, 2014 2:40 AM PDT

    Microwatt has "Run program" on a menu(click the right button).

    MATE version substitutes it in a terminal.

     

     

    This improves the work by other superusers.

    example: root user of PCmanFM and Caja 


    This post was edited by BALLOON a.k.a. Fu-sen. at May 13, 2014 3:03 AM PDT
    • 563 posts
    May 14, 2014 8:09 AM PDT

    Yes..this appears to be an installer bug, and a setting I did change during the build process because the livecd has it set to sudo if you check.., but after install it changes back to su.

     

    First time using this type of installer, so I will need to research a bit.

     

    Thanks for the screens and write up..I will pin this for others.

     

    biff

     


    This post was edited by biff baxter at May 14, 2014 8:10 AM PDT
    • 1 posts
    May 14, 2014 12:28 PM PDT
    Missed this and was having all sorts of trouble and Google didn't help, but Biff gave me the heads up. Also took a while to sort the keyboard, random errors in typing due to numlock enabled by default.
    Installed PAE kernel and now have fastest MATE install on my eeepc 901. Thanks, Roger.