Forums » wattOS R7

R7 - bugs and confirmed issues

    • 563 posts
    June 9, 2013 3:53 PM PDT

    I will be posting known bugs here (mostly upstream) and when reliable fixes become available, or confirmed patches, etc. address them I will put them here also. I am leaving this open for now, but expect it to be heavily moderated as I am only putting known issues here that impact everyone, not single user issues that might be related to your hardware specific install.

     

    • 563 posts
    June 9, 2013 3:54 PM PDT

    Bug #1 - Confirmed - Not addressed yet

     

    wattOS R7 liveCD - all versions. Seems to hang on shutdown of the liveCD. The problem is not present after install of the OS.

     

    • 1 posts
    June 14, 2013 2:44 AM PDT

    I have download the new version without the LXDE envoirement. I can ADD or EDIT network connection

    I cant connect tho the internet.

     

    I get error code 32 , admin rights or something.I have tried in groups to become admin , but problem still the same. Its a new install true live boot.

     

    I hope someone can help me out.

     

    Sorry for the bad english im from Holland.

     

    Reguards

     

    Bastiaan

    • 563 posts
    June 14, 2013 9:19 AM PDT

    Hi there - there are likely a couple ways to get around this. the quickest is to open a terminal and enter the command

     

    sudo nm-connection-editor

     

    then enter your password. That will give you sufficient rights. 

     

    The second option (permanent - so you can always change your wireless settings) is to follow the procedure below.

     

    +++++++++++++++++++++++++++++

    Bug #2 - confirmed for Microwatt Only - Addressed - cannot edit wired/wireless connections by default

     

    - The work around temporarily is to use the command noted above.

     

    - The permanent fix is as follows

     

    - Create a file in the path and name noted below (using whatever method you like)

     

    /etc/polkit-1/localauthority/50local.d/org.freedesktop.NetworkManager.pkla

     

    or use the command below in a terminal

     

    sudo nano /etc/polkit-1/localauthority/50-local.d/org.freedesktop.NetworkManager.pkla


    Then paste these contents


    [nm-applet]
    Identity=unix-group:netdev
    Action=org.freedesktop.NetworkManager.*
    ResultAny=yes
    ResultInactive=no
    ResultActive=yes


    Then save the file (you can use Ctrl+X and then answer "yes" to save the changes.

     

    last step is to add your user name to the netdev group

     

    from a terminal enter the command


    sudo usermod -a -G netdev your-user-name


    Then logout and login and you will be functioning properly



    This post was edited by biff baxter at June 14, 2013 9:23 AM PDT
    • 16 posts
    June 15, 2013 3:57 AM PDT
    biff baxter said:

    Bug #1 - Confirmed - Not addressed yet

     

    wattOS R7 liveCD - all versions. Seems to hang on shutdown of the liveCD. The problem is not present after install of the OS.

     

    Biff, I have the exact opposite problem. OK in live mode, hangs after installing. I had the same issue with Kubuntu when I tried that a few days back, Rob.

    • 563 posts
    June 15, 2013 6:17 PM PDT

    Bug #3 confirmed - Microwatt Only

     

    xfburn shows a gstreamer error on launch. It still works properly for CD burning, but is missing a file it is looking for. 

     

    To resolve make sure the following packages are installed.

     

    gstreamer0.10-plugins-base

    libgstreamer-plugins-base0.10


    using either synaptic package manager or command line (sudo apt-get install)


    This will make the error go away for users of xfburn.



    • 94 posts
    July 16, 2013 2:25 AM PDT

    u couldn't get update manger or package manager working for me in microwatt, wattos is working except volume control is not shown in taskbar.

  • August 6, 2013 3:53 AM PDT

    How can I resolve the bug in r7 where pcmanfm will not allow me to open samba shares. I read somewhere that a newer version of pcmanfm needs to be installed. Not sure how to go about doing this.

     

    Thanks!!

    • 563 posts
    August 6, 2013 4:35 PM PDT

    David - I have a fix for the update manager - Will post in the next 24 hours after testing is completed.

     

    Randy - you can open SMB shares in pcmanfm. I do it currently in wattOS R7. Can you tell me if its 32 or 64bit, and a little more info about the share and method you are trying to connect. It is a little wonky, but it does work.

     

    tks...biff

    • 11 posts
    August 11, 2013 11:56 PM PDT

    Hello, 

    last week on vm - dunno the version of it, on win32 machine, i try to test the R7, didn't go even from the boot menu

    now, with Virtual box on win32 version 4.2.16 r.... it working..

    the R7 32 bit, flawless

     

    but on the same vm microwatt didn't want to install, at the almost finishing the process of installing it gives me back the messages that something is with error during the install and have to send the errors...

     

    Thanks

    • 563 posts
    August 13, 2013 8:14 PM PDT

    david - To make the update manager display properly in Microwatt - do the following

     

    go to /usr/share/applications and edit the update-manager.desktop file (in pcmanfm GUI mode its called - Software Updater). 

     

    Change the line that says

     

    Exec= /usr/bin/update-manager

     

    to 

     

    Exec=gksu /usr/bin/update-manager

     

    Save the file and give it a go....I tried it on 3 systems with success.

     

    This will make the program prompt you for superuser credentials when launching and will have the update manager behave as it should.

  • September 18, 2013 10:14 AM PDT

    All I am doing is accessing Network Drives from the Go menu in a pcmanfm window. When I go to open any of the shares, I get the error message:

     

    The specified location is not mounted.

    • 53 posts
    October 28, 2013 6:08 PM PDT

    Fantastic! I ended up updating 7.x to Sundered Salamander or whatever and it runs same-o until I look at network connections and they pretend to be disabled. Not so easily remedied as a sudo service wallawumpus start ?    except that I see some xorg segfaults in the log? (Core2 T5500/945GM/didn't update wattOS-customized initscripts)

    [ 112.388962] [drm:intel_pipe_config_compare] *ERROR* mismatch in adjusted_mode.flags (expected 2, found 0)
    [ 112.388972] ------------[ cut here ]------------
    [ 112.389028] WARNING: CPU: 0 PID: 1031 at /build/buildd/linux-3.11.0/drivers/gpu/drm/i915/intel_display.c:8292 check_crtc_s$
    [ 112.389033] pipe state doesn't match!
    [ 112.389037] Modules linked in: dm_crypt(F) usb_storage(F) coretemp kvm(F) ohci_pci gpio_ich parport_pc(F) ppdev(F) dell_wm$
    [ 112.389144] CPU: 0 PID: 1031 Comm: Xorg Tainted: GF W 3.11.0-12-generic #19-Ubuntu
    [ 112.389149] Hardware name: Dell Inc. Latitude D520 /0NF743, BIOS A06 05/28/2007
    [ 112.389154] 00000000 00000000 f28e18b0 c162566b f28e18f0 f28e18e0 c105273e f86f5d40
    [ 112.389169] f28e190c 00000407 f86ed730 00002064 f86a7630 f86a7630 f645564c f6455000
    [ 112.389184] 0000000a f28e18f8 c1052793 00000009 f28e18f0 f86f5d40 f28e190c f28e1b60
    [ 112.389198] Call Trace:
    [ 112.389213] [] dump_stack+0x41/0x52
    [ 112.389223] [] warn_slowpath_common+0x7e/0xa0
    [ 112.389265] [] ? check_crtc_state+0x590/0xb30 [i915]
    [ 112.389305] [] ? check_crtc_state+0x590/0xb30 [i915]
    [ 112.389313] [] warn_slowpath_fmt+0x33/0x40
    [ 112.389353] [] check_crtc_state+0x590/0xb30 [i915]
    [ 112.389403] [] intel_modeset_check_state+0x2a3/0x760 [i915]
    [ 112.389450] [] intel_set_mode+0x30/0x40 [i915]
    [ 112.389491] [] intel_get_load_detect_pipe+0x230/0x3a0 [i915]
    [ 112.389545] [] intel_tv_detect+0xe7/0x4a0 [i915]
    [ 112.389558] [] ? __i2c_transfer+0x55/0x70
    [ 112.389575] [] drm_helper_probe_single_connector_modes+0x1b8/0x340 [drm_kms_helper]
    [ 112.389618] [] drm_mode_getconnector+0x2fd/0x350 [drm]
    [ 112.389653] [] ? drm_mode_getcrtc+0xc0/0xc0 [drm]
    [ 112.389678] [] drm_ioctl+0x49a/0x540 [drm]
    [ 112.389713] [] ? drm_mode_getcrtc+0xc0/0xc0 [drm]
    [ 112.389725] [] ? __switch_to_xtra+0xfe/0x130
    [ 112.389735] [] ? set_next_entity+0xaf/0xe0
    [ 112.389744] [] ? __switch_to+0x2b8/0x340
    [ 112.389769] [] ? drm_copy_field+0x70/0x70 [drm]
    [ 112.389778] [] do_vfs_ioctl+0x2e6/0x4e0
    [ 112.389786] [] ? __schedule+0x35e/0x790
    [ 112.389794] [] ? __sb_end_write+0x31/0x70
    [ 112.389802] [] ? vfs_write+0x155/0x1b0
    [ 112.389810] [] SyS_ioctl+0x60/0x80
    [ 112.389818] [] sysenter_do_call+0x12/0x28
    [ 112.389824] ---[ end trace 874fb73c3b63b5a0 ]---


    This post was edited by Saigua Tang at October 28, 2013 10:40 PM PDT
    • 105 posts
    October 30, 2013 12:23 AM PDT

    welcome to the land of mistakes Saigua!

     

    I learnt a good while back to never upgrade a distro to a newer version as stuff will break, especially with custom offshoots like WattOS.

    Unfortunately you cant downgrade once upgraded and fixes are usually very long labourious and no guarentee of working.

    My initial reaction to this , and this is solely my view please note...., is back up your documents and pictures , videos.. to an external source and fresh install 7.5 again.

     

    we will soon have a post up on the forum on how to disable the upgrade notification from software updater.

    • 20 posts
    November 14, 2013 4:13 AM PST

    So yes, I was awaiting wattos R7 so mush, but since it is realise I had no time to try any versions.  Now, I just tried to install wattos R7 64 on my HP compaq cd5100 MT. My HD had windows 7 and wattos R6 installed on. I would erase everything on and install new wattos. I choosed option of security key encrypt and LVM. My installation failed. I guess it is why the last version is now 7.5. : Am I right there ?

    • 105 posts
    November 14, 2013 12:47 PM PST

    I havent run an install with encrypt and lvm yet so i cant comment on that side.. but 7.5 with standard settings works a treat :)

    • 20 posts
    November 15, 2013 5:25 AM PST

    I just tried wattos R7.5 64 on my HP compaq cd5100 MT in live cd. There it seems to work but I' prompted for user name and password. I tried guess htan! I see my mistake : It was guest. Right, I go try that.


    • 20 posts
    November 15, 2013 6:01 AM PST

    There again. Hello my friends I m now runing wattos R 7.5 64 on my HP compaq cd5100 MT 2007 with 3g ram. A wonderful background appear . It is a great job. Well then I try to install on my 80g HD that had a windows 7 and wattos r6 64 on. I would just erase everything and install new. Again the operations failed. I will now try with another HD.

    • 53 posts
    November 16, 2013 9:17 PM PST

    Gerry, thanks. Do you happen to know how to put folding on a paragraph so uninteresting code doesn't show? (i.e. folding: can I has?)

    The dern thing seems to have straightened itself out, though of course I can't consider it canon WattOS now. The only trouble seems to be a nice wlan0 delf-deauthentication when I close the laptop lid, very sensible...except if I want to re-enable networking where in Ubuntu forums I should have checked (before closing the lid!) Services don't do much when asked to restart (80211? no. networking? nothing much to restart... sudo dhclient wlan0? sure! What?)

     

    Ghyslain: I wish I knew what even showed up in the installer app or dmesg following your troubles; otherwise it's unclear why things failed, other than your need to remove the partitions you no longer need and provide a bootable one and supported one. It's common to have /boot on ext4 or btrfs, then / and /home on xfs or btrfs (but with some preference to letting a hybrid flash and magnetic storage volume handle it, so /tmp, /var/log/ etc. do not affect seek() load and delays.

    • 563 posts
    November 21, 2013 9:47 PM PST

    Greetings all...I typically tell people to not encrypt on install as its always been a problem. Its easy to do after the install. Ghyslain - thanks for sticking with it and keeping us up to date :)

     

    Look for me this weekend online and next week I will have some time to have some nerd fun with wattOS..